package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(?:\\.|[^\\"])*"|'(?:\\.|[^\\'])*'|[^\s"']+`)
var str = `Lorem ipsum ("dolor sit amet") consectetur "adipiscing \"elit" dolor 'something here'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}