const regex = /(?i)(?<=\/)pathElement(?=\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?<=\\\/)pathElement(?=\\\/)', 'gm')
const str = `https://www.host.com/pathElement/index.html
https://www.host.com/context/pathElement/index.html
https://www.host.com/context/subContext/pathElement/index.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}