re = /(?i)(?<=\/)pathElement(?=\/)/m
str = 'https://www.host.com/pathElement/index.html
https://www.host.com/context/pathElement/index.html
https://www.host.com/context/subContext/pathElement/index.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end