using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Diagnostic-Code:\s+?(.*)";
string input = @"Diagnostic-Code: smtp; 550-5.1.1 The email account that you tried to reach does
not exist. Please try 550-5.1.1 double-checking the recipient's email
address for typos or 550-5.1.1 unnecessary spaces. Learn more at 550 5.1.1
https://support.google.com/mail/?p=NoSuchUser 63si4621095ybi.465 - gsmtp";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}