$re = '`^\w+/(?:\w+/)*\w+(?:\.\w+)?$`m';
$str = 'data/files.xml
share/home.html
demo45/photos
demo45/photos/holiday/2015/bahamas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);