re = /^\w+\/(?:\w+\/)*\w+(?:\.\w+)?$/m
str = 'data/files.xml
share/home.html
demo45/photos
demo45/photos/holiday/2015/bahamas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end