package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\bdog\w*)|(\w*cat\b)`)
var str = `dog cat catdog dogcat 1dog file.dog dog.cat dog-cat banana bananacat dogapple-bananacat dog32 123cat dog12cat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}