import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s).*?(\\z|\\d+\\.\\d+\\.\\d+\\.\\d+)";
final String string = "Nmap scan report for 192.168.0.21\n"
+ "Host is up (0.18s latency).\n"
+ "Not shown: 1 filtered port\n"
+ "Some closed ports may be reported as filtered due to --defeat-rst-ratelimit\n"
+ "PORT STATE SERVICE\n"
+ "22/tcp open ssh\n\n"
+ "Nmap scan report for 192.168.0.29\n"
+ "Host is up (0.029s latency).\n"
+ "Not shown: 1 filtered port\n"
+ "Some closed ports may be reported as filtered due to --defeat-rst-ratelimit\n"
+ "PORT STATE SERVICE\n"
+ "22/tcp open ssh\n\n"
+ "Nmap scan report for 192.168.0.25\n"
+ "Host is up (0.15s latency).\n"
+ "Not shown: 1 filtered port\n"
+ "Some closed ports may be reported as filtered due to --defeat-rst-ratelimit\n"
+ "PORT STATE SERVICE\n"
+ "22/tcp open ssh";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}