const regex = /(?s).*?(\z|\d+\.\d+\.\d+\.\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s).*?(\\z|\\d+\\.\\d+\\.\\d+\\.\\d+)', 'gm')
const str = `Nmap scan report for 192.168.0.21
Host is up (0.18s latency).
Not shown: 1 filtered port
Some closed ports may be reported as filtered due to --defeat-rst-ratelimit
PORT STATE SERVICE
22/tcp open ssh
Nmap scan report for 192.168.0.29
Host is up (0.029s latency).
Not shown: 1 filtered port
Some closed ports may be reported as filtered due to --defeat-rst-ratelimit
PORT STATE SERVICE
22/tcp open ssh
Nmap scan report for 192.168.0.25
Host is up (0.15s latency).
Not shown: 1 filtered port
Some closed ports may be reported as filtered due to --defeat-rst-ratelimit
PORT STATE SERVICE
22/tcp open ssh`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);