$re = '/((\w{2}\d{4}\w)\/(\w{2}\d{4}\w\d{2}\w{3}))\s(\w{6})\s(\w+)\/(\d{4})\s(\d{4})/m';
$str = ' LMZ333 ALLOTMENT (0000) *TSC
HDQRM5I
.MADRIIB 160846
MADIB HQXL4/MADIB0009/7849644/MAD/IB/A/ES//RC//
1CUVILEON/CARLOS EDUARDO
5I8397J/IB2198J25JUN RZGMAD CS1/0850 1220
5I8327J/IB2194J06JUL MADRZG CS1/1745 2115
OSI 5I CTCP 34606686051-M
OSI 5I POSI-DSAC//MADIB08AB/I/1
OSI 5I CARLOSCUVILIN//GMAIL.COM
=
˜ ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);