# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\w{2}\d{4}\w)\/(\w{2}\d{4}\w\d{2}\w{3}))\s(\w{6})\s(\w+)\/(\d{4})\s(\d{4})"
test_str = (" LMZ333 ALLOTMENT (0000) *TSC\n"
"HDQRM5I\n"
".MADRIIB 160846\n"
"MADIB HQXL4/MADIB0009/7849644/MAD/IB/A/ES//RC//\n"
"1CUVILEON/CARLOS EDUARDO\n"
"5I8397J/IB2198J25JUN RZGMAD CS1/0850 1220\n"
"5I8327J/IB2194J06JUL MADRZG CS1/1745 2115\n"
"OSI 5I CTCP 34606686051-M\n"
"OSI 5I POSI-DSAC//MADIB08AB/I/1\n"
"OSI 5I CARLOSCUVILIN//GMAIL.COM\n"
"= \n"
"˜ ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.