$re = '/^([^:]+):|(?:\s)([^,]+)(?:,|$)/m';
$str = 'Junk line: this part, here, should work, but: make sure, that last colon, isn\'t caught
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);