re = /^([^:]+):|(?:\s)([^,]+)(?:,|$)/m
str = 'Junk line: this part, here, should work, but: make sure, that last colon, isn\'t caught
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end