$re = '/^1?\s?\d{3}(\s|\-)?\d{3}(\s|\-)?\d{4}/m';
$str = '555-555-5555
5555555555
1 555-555-5555
1 555 555 5555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);