// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^1?\s?\d{3}(\s|\-)?\d{3}(\s|\-)?\d{4}").unwrap();
let string = "555-555-5555
5555555555
1 555-555-5555
1 555 555 5555";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}