package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(\bwood[a-z]*)\b`)
var str = `wood and stuff
this doesnt contain the keyword
Wooding is what we do`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}