$re = '/\b(\bwood[a-z]*)\b/i';
$str = 'wood and stuff
this doesnt contain the keyword
Wooding is what we do';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);