#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[A-Z])(?=.*[a-z])(?=.*[\d])([A-Za-z\d]{8,})$"
Local $sString = "aaaaaaaa" & @CRLF & _
"AAAAAAAA" & @CRLF & _
"00000000" & @CRLF & _
"asdfFDSA167" & @CRLF & _
"#fFaf9374A" & @CRLF & _
"12345dfssA" & @CRLF & _
"123456NBh"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")