$re = '/^(?=.*[A-Z])(?=.*[a-z])(?=.*[\d])([A-Za-z\d]{8,})$/m';
$str = 'aaaaaaaa
AAAAAAAA
00000000
asdfFDSA167
#fFaf9374A
12345dfssA
123456NBh';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);