$re = '/(?=room|food|bed)/';
$str = 'The rooms rooms and rooms again were great, the food was not but the beds were extremely comfortable.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);