re = /(?=room|food|bed)/
str = 'The rooms rooms and rooms again were great, the food was not but the beds were extremely comfortable.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end