#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(\d{6}\_\d{9})\=.*(gurlan,danu)"
Local $sString = "[7384] [Birthdays] " & @CRLF & _
"[7384] 180528_201747263=198202141300 " & @CRLF & _
"[7384] 180528_210749326=19840222 " & @CRLF & _
"[7384] 180528_211723352=19831207 " & @CRLF & _
"[7384] 180528_211845500=201607072350 " & @CRLF & _
"[7384] 180528_212024116=19591231 " & @CRLF & _
"[7384] 180528_212038465=19590323 " & @CRLF & _
"[7384] 180528_213357273=19590811 " & @CRLF & _
"[7384] 180528_213701342=19780608 " & @CRLF & _
"[7384] " & @CRLF & _
"[7384] [NameSurname] " & @CRLF & _
"[7384] 180528_201747263=Gurlan V. Vasile aka. Licuta " & @CRLF & _
"[7384] 180528_210749326=Gurlan (Enea) V. Maria aka Mariana " & @CRLF & _
"[7384] 180528_211723352=Danu (Gurlan) F. Oana Nicoleta aka. Nikol " & @CRLF & _
"[7384] 180528_211845500=Gurlan V. Rebecca-Ioana " & @CRLF & _
"[7384] 180528_212024116=Gurlan P. Vasile " & @CRLF & _
"[7384] 180528_212038465=Nucu (Gurlan) N. Maria " & @CRLF & _
"[7384] 180528_213357273=Bogdan (Danu) G. Elena " & @CRLF & _
"[7384] 180528_213701342=Enea D. Ioan Dorin " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")