import re
regex = re.compile(r"(\d{6}\_\d{9})\=.*(gurlan,danu)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("[7384] [Birthdays] \n"
"[7384] 180528_201747263=198202141300 \n"
"[7384] 180528_210749326=19840222 \n"
"[7384] 180528_211723352=19831207 \n"
"[7384] 180528_211845500=201607072350 \n"
"[7384] 180528_212024116=19591231 \n"
"[7384] 180528_212038465=19590323 \n"
"[7384] 180528_213357273=19590811 \n"
"[7384] 180528_213701342=19780608 \n"
"[7384] \n"
"[7384] [NameSurname] \n"
"[7384] 180528_201747263=Gurlan V. Vasile aka. Licuta \n"
"[7384] 180528_210749326=Gurlan (Enea) V. Maria aka Mariana \n"
"[7384] 180528_211723352=Danu (Gurlan) F. Oana Nicoleta aka. Nikol \n"
"[7384] 180528_211845500=Gurlan V. Rebecca-Ioana \n"
"[7384] 180528_212024116=Gurlan P. Vasile \n"
"[7384] 180528_212038465=Nucu (Gurlan) N. Maria \n"
"[7384] 180528_213357273=Bogdan (Danu) G. Elena \n"
"[7384] 180528_213701342=Enea D. Ioan Dorin \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")