package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`0*1*0*+(1+00+000)*+(0+1+0+)*`)
var str = `01000100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}