$re = '/0*1*0*+(1+00+000)*+(0+1+0+)*/';
$str = '01000100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);