using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\bdetails\.cfm\b).*\bselector=size\b.*$";
string input = @"http://www.anydotcom.com/test/search.cfm?metric=blah&abcselector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah2&selector=style&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=sizeabc&value=1
http://www.anydotcom.com/test/details.cfm?metric=blah&selector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah&selector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah3&value=1&selector=size
http://www.anydotcom.com/test/search.cfm?metric=blah&value=1&selector=size
http://www.anydotcom.com/test/details.cfmabc?metric=blah&selector=size&value=1
http://www.anydotcom.com/test/abcdetails.cfm?metric=blah&selector=size&value=1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}