const regex = new RegExp('^(?!.*\\bdetails\\.cfm\\b).*\\bselector=size\\b.*$', 'gm')
const str = `http://www.anydotcom.com/test/search.cfm?metric=blah&abcselector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah2&selector=style&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=sizeabc&value=1
http://www.anydotcom.com/test/details.cfm?metric=blah&selector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah3&selector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah&selector=size&value=1
http://www.anydotcom.com/test/search.cfm?metric=blah3&value=1&selector=size
http://www.anydotcom.com/test/search.cfm?metric=blah&value=1&selector=size
http://www.anydotcom.com/test/details.cfmabc?metric=blah&selector=size&value=1
http://www.anydotcom.com/test/abcdetails.cfm?metric=blah&selector=size&value=1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}