const regex = /(?<!:)?:\K([0-9.]+)(?=:[[:alpha:]])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!:)?:\\K([0-9.]+)(?=:[[:alpha:]])', 'gm')
const str = `ip=10.0.20.100::10.0.20.1:255.255.254.0:ws01.example.com::off`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}