$re = '/(?<!:)?:\K([0-9.]+)(?=:[[:alpha:]])/m';
$str = 'ip=10.0.20.100::10.0.20.1:255.255.254.0:ws01.example.com::off';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);