using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|(?:\A[^""]*|[^""]*"",\s*)(?:""[^""]*"",\s*)*+"")[^""]*\K""(?!\s*[\],])";
string input = @"[""my cars last night"",
""Burger"",""Decaf"" sh""irt"",
""Mocha"",""marshmallows"",
""Coffee Mission""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}