$re = '/(?:\G(?!\A)|(?:\A[^"]*|[^"]*",\s*)(?:"[^"]*",\s*)*+")[^"]*\K"(?!\s*[\],])/';
$str = '["my cars last night",
"Burger","Decaf" sh"irt",
"Mocha","marshmallows",
"Coffee Mission"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);