$re = '/\b\w+\b(?:.*?\b\w+\b){2}/m';
$str = 'foo bar buz
foo bar
bar
buz bar foo foobar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);