re = /\b\w+\b(?:.*?\b\w+\b){2}/m
str = 'foo bar buz
foo bar
bar
buz bar foo foobar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end