const regex = /^([0-9]+)(,\s?[0-9]+)*,?\s?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]+)(,\\s?[0-9]+)*,?\\s?$', 'gm')
const str = `34423, 234324, 324234, 2343423,3424324,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}