re = /^([0-9]+)(,\s?[0-9]+)*,?\s?$/m
str = '34423, 234324, 324234, 2343423,3424324,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end