#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\[(?<first>icode|quote|code)[^\]]*?\](?:[\s]*?.)*?[\s]*?\[\/(\k<first>)\])(*SKIP)(*F)|(?![^<]*>|[^\[]*\])"([^"]*?)""
Local $sString = "[quote]Id in voluptatem [U]odit itaque[/U] ea. Qui eum [URL='http://#']fugiat[/URL] doloribus dicta nisi. [icode]Exercitationem sit error maxime aperiam quaerat hic deleniti quidem[/icode]. Totam laudantium aut quia. "Sint ut ut vel ratione," Qui porro eaque enim fugit." & @CRLF & _
"[/quote]" & @CRLF & _
"" & @CRLF & _
"Quam consequatur consequatur voluptate molestiae explicabo [icode]qui consectetur[/ICODE], "Voluptatem saepe [b]ex adipisci aut est rem[/b]." Numquam a cupiditate non officiis sed aspernatur." & @CRLF & _
"" & @CRLF & _
"[quote="Lorem Ipsum, post: 12345, member: 123"]Aut deleniti nihil sit. Saepe dolorem blanditiis nemo. Ab et cumque nesciunt. Quos velit vel nam porro.[/quote]" & @CRLF & _
"" & @CRLF & _
"[spoiler="Name"]Unde et eius tempore consequatur. "Vitae est ut et," est numquam.""[/spoiler]" & @CRLF & _
"" & @CRLF & _
"Quo <span style="color: #24c4f9"><b>suscipit</b></span> sequi id ratione "doloribus omnis"." & @CRLF & _
"" & @CRLF & _
"<span style="font-family: 'Lucida Console'"><span style="font-size: 18px">Lorem ipsum dolor sit amet, consectetur adipiscing elit." & @CRLF & _
""" & @CRLF & _
"Maecenas sed nibh ac neque semper finibus." & @CRLF & _
"Saepe dolorem blanditiis nemo." & @CRLF & _
""" & @CRLF & _
"</b></span>" & @CRLF & _
"" & @CRLF & _
"[CODE=html]" & @CRLF & _
"" & @CRLF & _
"Vivamus hendrerit augue "volutpat", consequat risus sed, dignissim orci." & @CRLF & _
"" & @CRLF & _
"Fusce sed pellentesque ipsum. Suspendisse nisi odio, gravida sed leo ut, tristique posuere felis." & @CRLF & _
"[/CODE]" & @CRLF & _
"" & @CRLF & _
"Ut tempor vestibulum viverra. Vivamus imperdiet fringilla est fermentum facilisis. Quisque nec massa sit amet augue eleifend condimentum at nec arcu." & @CRLF & _
"" & @CRLF & _
"[CENTER][B]Quam consequa[/B] "tur c[I]onse[/I]quatur". Eum molestias "et" doloribus et rem dolorem vero qui.[/CENTER]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")