re = /(\[(?<first>icode|quote|code)[^\]]*?\](?:[\s]*?.)*?[\s]*?\[\/(\k<first>)\])(*SKIP)(*F)|(?![^<]*>|[^\[]*\])"([^"]*?)"/i
str = '[quote]Id in voluptatem [U]odit itaque[/U] ea. Qui eum [URL=\'http://#\']fugiat[/URL] doloribus dicta nisi. [icode]Exercitationem sit error maxime aperiam quaerat hic deleniti quidem[/icode]. Totam laudantium aut quia. "Sint ut ut vel ratione," Qui porro eaque enim fugit.
[/quote]
Quam consequatur consequatur voluptate molestiae explicabo [icode]qui consectetur[/ICODE], "Voluptatem saepe [b]ex adipisci aut est rem[/b]." Numquam a cupiditate non officiis sed aspernatur.
[quote="Lorem Ipsum, post: 12345, member: 123"]Aut deleniti nihil sit. Saepe dolorem blanditiis nemo. Ab et cumque nesciunt. Quos velit vel nam porro.[/quote]
[spoiler="Name"]Unde et eius tempore consequatur. "Vitae est ut et," est numquam.""[/spoiler]
Quo <span style="color: #24c4f9"><b>suscipit</b></span> sequi id ratione "doloribus omnis".
<span style="font-family: \'Lucida Console\'"><span style="font-size: 18px">Lorem ipsum dolor sit amet, consectetur adipiscing elit.
"
Maecenas sed nibh ac neque semper finibus.
Saepe dolorem blanditiis nemo.
"
</b></span>
[CODE=html]
Vivamus hendrerit augue "volutpat", consequat risus sed, dignissim orci.
Fusce sed pellentesque ipsum. Suspendisse nisi odio, gravida sed leo ut, tristique posuere felis.
[/CODE]
Ut tempor vestibulum viverra. Vivamus imperdiet fringilla est fermentum facilisis. Quisque nec massa sit amet augue eleifend condimentum at nec arcu.
[CENTER][B]Quam consequa[/B] "tur c[I]onse[/I]quatur". Eum molestias "et" doloribus et rem dolorem vero qui.[/CENTER]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end