import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*g)[fghlotu]{4,}$";
final String string = "// SB from 2019-10-05\n"
+ "// centerLetter: g\n"
+ "// outerLetters: f,h,l,o,t,u\n\n"
+ "// wrong letters\n"
+ "bread\n"
+ "butter\n"
+ "bigger\n"
+ "ogogogx\n"
+ "xogogog\n\n"
+ "// too short\n"
+ "gut\n"
+ "log\n"
+ "fgt\n\n"
+ "// no center letter\n"
+ "trout\n"
+ "lotto\n"
+ "full\n\n"
+ "// tricky cases that should match (made up words)\n"
+ "ogogog\n"
+ "gogog\n"
+ "ogogo\n"
+ "oggoggo\n"
+ "ggogg\n"
+ "ggoo\n"
+ "oogg\n\n"
+ "// actual solutions\n"
+ "thoughtful\n"
+ "flog\n"
+ "fought\n"
+ "fugu\n"
+ "ghoul\n"
+ "glut\n"
+ "golf\n"
+ "goof\n"
+ "googol\n"
+ "goth\n"
+ "gout\n"
+ "guff\n"
+ "gulf\n"
+ "gull\n"
+ "logo\n"
+ "ought\n"
+ "outfought\n"
+ "outgo\n"
+ "outthought\n"
+ "though\n"
+ "thought\n"
+ "thug\n"
+ "tough\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}