import Foundation
let pattern = #"^(?=.*g)[fghlotu]{4,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// SB from 2019-10-05
// centerLetter: g
// outerLetters: f,h,l,o,t,u
// wrong letters
bread
butter
bigger
ogogogx
xogogog
// too short
gut
log
fgt
// no center letter
trout
lotto
full
// tricky cases that should match (made up words)
ogogog
gogog
ogogo
oggoggo
ggogg
ggoo
oogg
// actual solutions
thoughtful
flog
fought
fugu
ghoul
glut
golf
goof
googol
goth
gout
guff
gulf
gull
logo
ought
outfought
outgo
outthought
though
thought
thug
tough
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)