// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*),(.*),(.*),(.*)").unwrap();
let string = "`value`, `sort_order`, `text`) VALUES ('6', '2', 'total', 'Ümumi', '11.0000', '9', '11.00 AZN');";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}