package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^4321.*`)
var str = `432133333333333
143213333
13444123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}