$re = '/^4321.*/';
$str = '432133333333333
143213333
13444123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);