$re = '/(^(?:[a-zA-Z0-9]+(?:\-*[a-zA-Z0-9])*\.)+[a-zA-Z]{2,6}$)/m';
$str = 'domain.com
do-main-.com
do-main--.com
-domain-.-.com
-domain.com
test--0.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);