re = /(^(?:[a-zA-Z0-9]+(?:\-*[a-zA-Z0-9])*\.)+[a-zA-Z]{2,6}$)/m
str = 'domain.com
do-main-.com
do-main--.com
-domain-.-.com
-domain.com
test--0.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end