re = /(?:\[|\G(?!^))('[^\\']*(?:\\.[^\\']*)*')\s*,?\s*(?=[^\]]*?\])/m
str = '[\'F\\\'oo\', \'B\\\'ar\']
eq(\'Property\', [\'F\\\'oo\', \'Ba\\\'r\', \'123\'])'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end