using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=!\..)\.(?!.\.)";
string input = @"Lalala, hello, Hello world. This is a test. This U.S. Navy, The World War yeaaaaah. Wut this is a.w.e.some.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}