$re = '/(?=!\..)\.(?!.\.)/';
$str = 'Lalala, hello, Hello world. This is a test. This U.S. Navy, The World War yeaaaaah. Wut this is a.w.e.some.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);