import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{4}$)(?:(.)(?!\\1)|0?1?|1?2?|2?3?|3?4?|4?5?|5?6?|6?7?|7?8?|8?9?|9?8?|8?7?|7?6?|6?5?|5?4?|4?3?|3?2?|2?1?|1?0?)$";
final String string = "abba\n"
+ "12341\n"
+ "1234\n"
+ "3456\n"
+ "9876\n"
+ "9988\n"
+ "1123\n"
+ "1357\n"
+ "6789\n"
+ "0123\n"
+ "3765\n"
+ "9356\n"
+ "0738\n"
+ "1485\n"
+ "1930";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}