re = /^(?:\d{4}$)(?:(.)(?!\1)|0?1?|1?2?|2?3?|3?4?|4?5?|5?6?|6?7?|7?8?|8?9?|9?8?|8?7?|7?6?|6?5?|5?4?|4?3?|3?2?|2?1?|1?0?)$/m
str = 'abba
12341
1234
3456
9876
9988
1123
1357
6789
0123
3765
9356
0738
1485
1930'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end