use strict;
my $str = '"25575"';
my $regex = qr/[0-9]{5}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";